Yue Tao b6dbc770fc monitor-helm-elastic: remove dl_hook
Use debian method to apply local patches instead of patching in rules.

Add "dl_path" and "src_files" in meta_data.yaml to download tarball and
copy local files.

No need dl_hook

Test Plan:

Pass: successfully build monitor-helm-elastic.
Pass: No difference comparing with the result of dl_hook

Story: 2009101
Task: 43838

Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
Change-Id: I068f3ae0cbf9e0661abc12adcec005be145f2462
2022-01-13 10:54:50 +08:00

62 lines
1.4 KiB
Diff

From c9c3e8ff214360eb2e5d9e7728b7bee8fe771eea Mon Sep 17 00:00:00 2001
From: Kevin Smith <kevin.smith@windriver.com>
Date: Tue, 1 Oct 2019 15:25:32 -0400
Subject: [PATCH 1/1] add makefile
---
Makefile | 44 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
index 00e154d..5cf4447
--- a/Makefile
+++ b/Makefile
@@ -1,1 +1,43 @@
-include helpers/common.mk
+#
+# Copyright 2017 The Openstack-Helm Authors.
+#
+# Copyright (c) 2018 Wind River Systems, Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# It's necessary to set this because some environments don't link sh -> bash.
+SHELL := /bin/bash
+TASK := build
+
+EXCLUDES := helm-toolkit doc tests tools logs tmp
+CHARTS := helm-toolkit $(filter-out $(EXCLUDES), $(patsubst %/.,%,$(wildcard */.)))
+
+.PHONY: $(EXCLUDES) $(CHARTS)
+
+all: $(CHARTS)
+
+$(CHARTS):
+ @if [ -d $@ ]; then \
+ echo; \
+ echo "===== Processing [$@] chart ====="; \
+ make $(TASK)-$@; \
+ fi
+
+init-%:
+ if [ -f $*/Makefile ]; then make -C $*; fi
+ if [ -f $*/requirements.yaml ]; then helm dep up $*; fi
+
+lint-%: init-%
+ if [ -d $* ]; then helm lint $*; fi
+
+build-%: lint-%
+ if [ -d $* ]; then helm package $*; fi
+
+clean:
+ @echo "Clean all build artifacts"
+ rm -f */templates/_partials.tpl */templates/_globals.tpl
+ rm -f *tgz */charts/*tgz */requirements.lock
+ rm -rf */charts */tmpcharts
+
+%:
+ @:
--
1.8.3.1