
Add debian package for python-horizon. Story: 2009101 Task: 43740 Signed-off-by: Fabricio Henrique Ramos <fabriciohenrique.ramos@windriver.com> Change-Id: If8906847a08e2d2ecfd2c721a04d4c0cfe7d8f0c
59 lines
2.9 KiB
Diff
59 lines
2.9 KiB
Diff
From 4807825b3505825fe1d5b5a65113b8b2ec29f244 Mon Sep 17 00:00:00 2001
|
|
From: Fabricio Henrique Ramos <fabriciohenrique.ramos@windriver.com>
|
|
Date: Fri, 22 Oct 2021 14:11:23 -0300
|
|
Subject: [PATCH] install extra files
|
|
|
|
---
|
|
debian/openstack-dashboard.install | 8 ++++++++
|
|
debian/python3-django-horizon.install | 1 +
|
|
debian/rules | 10 ++++++++++
|
|
3 files changed, 19 insertions(+)
|
|
|
|
diff --git a/debian/openstack-dashboard.install b/debian/openstack-dashboard.install
|
|
index 2be73b980..12f33b9eb 100644
|
|
--- a/debian/openstack-dashboard.install
|
|
+++ b/debian/openstack-dashboard.install
|
|
@@ -1,3 +1,11 @@
|
|
debian/local_settings.d/* usr/share/openstack-dashboard-debian-settings.d
|
|
etc/openstack-dashboard
|
|
+etc/httpd/conf.d/openstack-dashboard.conf
|
|
+etc/logrotate.d/openstack-dashboard
|
|
+etc/rc.d/init.d/horizon
|
|
usr/share/openstack-dashboard
|
|
+usr/share/openstack-dashboard/guni_config.py
|
|
+usr/bin/horizon-clearsessions
|
|
+usr/bin/horizon-patching-restart
|
|
+usr/bin/horizon-assets-compress
|
|
+usr/lib/systemd/system/httpd.service.d/openstack-dashboard.conf
|
|
diff --git a/debian/python3-django-horizon.install b/debian/python3-django-horizon.install
|
|
index 47e0ed436..a113003f0 100644
|
|
--- a/debian/python3-django-horizon.install
|
|
+++ b/debian/python3-django-horizon.install
|
|
@@ -1 +1,2 @@
|
|
/usr/lib/python*
|
|
+usr/share/doc/python3-django-horizon/openstack-dashboard-httpd-logging.conf
|
|
diff --git a/debian/rules b/debian/rules
|
|
index 53181a6a6..40e32724c 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -95,6 +95,16 @@ override_dh_auto_install:
|
|
## Delete not needed files
|
|
rm -f $(CURDIR)/debian/tmp/usr/lib/python3/dist-packages/openstack_dashboard/local/_build*.lock
|
|
|
|
+ install -D -p -m 644 $(CURDIR)/files/openstack-dashboard-httpd-2.4.conf $(CURDIR)/debian/tmp/etc/httpd/conf.d/openstack-dashboard.conf
|
|
+ install -D -p -m 644 $(CURDIR)/files/python-django-horizon-systemd.conf $(CURDIR)/debian/tmp/usr/lib/systemd/system/httpd.service.d/openstack-dashboard.conf
|
|
+ install -D -p $(CURDIR)/files/openstack-dashboard-httpd-logging.conf $(CURDIR)/debian/tmp/usr/share/doc/python3-django-horizon/openstack-dashboard-httpd-logging.conf
|
|
+ install -D -p $(CURDIR)/files/python-django-horizon-logrotate.conf $(CURDIR)/debian/tmp/etc/logrotate.d/openstack-dashboard
|
|
+ install -D -p -m 755 $(CURDIR)/files/horizon.init $(CURDIR)/debian/tmp/etc/rc.d/init.d/horizon
|
|
+ install -D -p -m 755 $(CURDIR)/files/horizon-clearsessions $(CURDIR)/debian/tmp/usr/bin/horizon-clearsessions
|
|
+ install -D -p -m 755 $(CURDIR)/files/horizon-patching-restart $(CURDIR)/debian/tmp/usr/bin/horizon-patching-restart
|
|
+ install -D -p $(CURDIR)/files/guni_config.py $(CURDIR)/debian/tmp/usr/share/openstack-dashboard/guni_config.py
|
|
+ install -D -p -m 755 $(CURDIR)/files/horizon-assets-compress $(CURDIR)/debian/tmp/usr/bin/horizon-assets-compress
|
|
+
|
|
dh_install
|
|
dh_missing --fail-missing
|
|
find $(CURDIR)/debian -iname .eslintrc -delete
|
|
--
|
|
2.17.1
|
|
|